$re = '/(<(?P<end>\/*)(A)(?P<number>\d+)>)(.*?)</\3\4>/s';
$str = '<T1>
<A1>
lorem ipsum
</A1>
</T1>';
$subst = "<test number=\"\g<number>\">\5</test>";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;