re = /(<(?P<end>\/*)(A)(?P<number>\d+)>)(.*?)<\/\3\4>/
str = '<T1>
<A1>
lorem ipsum
</A1>
</T1>'
subst = '<test number="\\g<number>">\\5</test>'
result = str.sub(re, subst)
# Print the result of the substitution
puts result