use strict;
my $str = '<T1>
<A1>
lorem ipsum
</A1>
</T1>';
my $regex = qr/(<(?P<end>\/*)(A)(?P<number>\d+)>)(.*?)</\3\4>/sp;
my $subst = '<test number="\\g<number>">\\5</test>';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";