const regex = new RegExp('(<(?P<end>\\/*)(A)(?P<number>\\d+)>)(.*?)</\\3\\4>', 's')
const str = `<T1>
<A1>
lorem ipsum
</A1>
</T1>`;
const subst = `<test number="\g<number>">\5</test>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);