#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)(<(?P<end>\/*)(A)(?P<number>\d+)>)(.*?)</\3\4>"
Local $sString = "<T1>" & @CRLF & _
" <A1>" & @CRLF & _
" lorem ipsum" & @CRLF & _
" </A1>" & @CRLF & _
" </T1>"
Local $sSubst = "<test number="\g<number>">\5</test>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)