import Foundation
let pattern = #"(<(?P<end>\/*)(A)(?P<number>\d+)>)(.*?)</\3\4>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
<T1>
<A1>
lorem ipsum
</A1>
</T1>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<test number="\g<number>">\5</test>"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}