import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<(?P<end>\\/*)(A)(?P<number>\\d+)>)(.*?)</\\3\\4>";
final String string = "<T1>\n"
+ " <A1>\n"
+ " lorem ipsum\n"
+ " </A1>\n"
+ " </T1>";
final String subst = "<test number=\"\\g<number>\">\\5</test>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}