# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\caption{((?:[^\\{}]|\\.)*)}/\\caption{\\scriptsize\\textbf{$1}}/g;t' <<< "%ORIGINAL
\caption{ Some \{ \}text
some other text }
%...
\env2{ \caption{ Other text } }"