import Foundation
let pattern = #"\\caption{((?:[^\\{}]|\\.)*)}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
%ORIGINAL
\caption{ Some \{ \}text
some other text }
%...
\env2{ \caption{ Other text } }
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\\caption{\\scriptsize\\textbf{$1}}"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)