$re = '/\\\\caption{((?:[^\\\\{}]|\\\\.)*)}/';
$str = '%ORIGINAL
\\caption{ Some \\{ \\}text
some other text }
%...
\\env2{ \\caption{ Other text } }';
$subst = "\\caption{\\scriptsize\\textbf{$1}}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;