using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\caption{((?:[^\\{}]|\\.)*)}";
string substitution = @"\\caption{\\scriptsize\\textbf{$1}}";
string input = @"%ORIGINAL
\caption{ Some \{ \}text
some other text }
%...
\env2{ \caption{ Other text } }";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}