use strict;
my $str = '%ORIGINAL
\\caption{ Some \\{ \\}text
some other text }
%...
\\env2{ \\caption{ Other text } }';
my $regex = qr/\\caption{((?:[^\\{}]|\\.)*)}/p;
my $subst = '\\\\caption{\\\\scriptsize\\\\textbf{$1}}';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";