package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\\caption{((?:[^\\{}]|\\.)*)}`)
var str = `%ORIGINAL
\caption{ Some \{ \}text
some other text }
%...
\env2{ \caption{ Other text } }`
var substitution = "\\caption{\\scriptsize\\textbf{$1}}"
fmt.Println(re.ReplaceAllString(str, substitution))
}