// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\\caption{((?:[^\\{}]|\\.)*)}").unwrap();
let string = "%ORIGINAL
\\caption{ Some \\{ \\}text
some other text }
%...
\\env2{ \\caption{ Other text } }";
let substitution = "\\\\caption{\\\\scriptsize\\\\textbf{$1}}";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}