# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/src="([^'"]+)"/src="{% static '\1' %}"/g;t' <<< "<img src=\"images/logo.png\" />
<img src=\"{% static 'img/logo.png' %}\" />"