import re
regex = re.compile(r"src=\"([^'\"]+)\"")
test_str = ("<img src=\"images/logo.png\" />\n"
"<img src=\"{% static 'img/logo.png' %}\" />")
subst = "src=\"{% static '\\1' %}\""
result = regex.sub(subst, test_str)
if result:
print(result)