$re = '/src="([^\'"]+)"/';
$str = '<img src="images/logo.png" />
<img src="{% static \'img/logo.png\' %}" />';
$subst = "src=\"{% static '\1' %}\"";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;