re = /src="([^'"]+)"/
str = '<img src="images/logo.png" />
<img src="{% static \'img/logo.png\' %}" />'
subst = 'src="{% static \'\\1\' %}"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result