use strict;
my $str = '<img src="images/logo.png" />
<img src="{% static \'img/logo.png\' %}" />';
my $regex = qr/src="([^'"]+)"/p;
my $subst = 'src="{% static \'\\1\' %}"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";