import Foundation
let pattern = #"src="([^'"]+)""#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<img src="images/logo.png" />
<img src="{% static 'img/logo.png' %}" />
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"src="{% static '\1' %}""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)