using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"src=""([^'""]+)""";
string substitution = @"src=""{% static '\1' %}""";
string input = @"<img src=""images/logo.png"" />
<img src=""{% static 'img/logo.png' %}"" />";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}