# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^[0-9]{4}?[0-9]$|^[0-9]{4}?[0-9]-[0-9]{4}$)//gm;t' <<< "12345-1234
12345
1
12
123
1234
12345-
12345-1
12345-12
12345-123
"