const regex = /(^[0-9]{4}?[0-9]$|^[0-9]{4}?[0-9]-[0-9]{4}$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^[0-9]{4}?[0-9]$|^[0-9]{4}?[0-9]-[0-9]{4}$)', 'gm')
const str = `12345-1234
12345
1
12
123
1234
12345-
12345-1
12345-12
12345-123
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);