import re
regex = re.compile(r"(^[0-9]{4}?[0-9]$|^[0-9]{4}?[0-9]-[0-9]{4}$)", flags=re.MULTILINE)
test_str = ("12345-1234\n"
"12345\n"
"1\n"
"12\n"
"123\n"
"1234\n"
"12345-\n"
"12345-1\n"
"12345-12\n"
"12345-123\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)