using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[0-9]{4}?[0-9]$|^[0-9]{4}?[0-9]-[0-9]{4}$)";
string substitution = @"";
string input = @"12345-1234
12345
1
12
123
1234
12345-
12345-1
12345-12
12345-123
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}