import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^[0-9]{4}?[0-9]$|^[0-9]{4}?[0-9]-[0-9]{4}$)";
final String string = "12345-1234\n"
+ "12345\n"
+ "1\n"
+ "12\n"
+ "123\n"
+ "1234\n"
+ "12345-\n"
+ "12345-1\n"
+ "12345-12\n"
+ "12345-123\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}