import Foundation
let pattern = #"(^[0-9]{4}?[0-9]$|^[0-9]{4}?[0-9]-[0-9]{4}$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
12345-1234
12345
1
12
123
1234
12345-
12345-1
12345-12
12345-123
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)