# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/http:\/\/v\.youku\.com\/v_show\/id_(\w+)\.html/$1/;t' <<< "http://v.youku.com/v_show/id_XNTg3OTc3MzY4.html"