#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "http://v\.youku\.com/v_show/id_(\w+)\.html"
Local $sString = "http://v.youku.com/v_show/id_XNTg3OTc3MzY4.html"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)