const regex = /http://v\.youku\.com/v_show/id_(\w+)\.html/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('http:\/\/v\\.youku\\.com\/v_show\/id_(\\w+)\\.html', '')
const str = `http://v.youku.com/v_show/id_XNTg3OTc3MzY4.html`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);