use strict;
my $str = 'http://v.youku.com/v_show/id_XNTg3OTc3MzY4.html';
my $regex = qr/http://v\.youku\.com/v_show/id_(\w+)\.html/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";