re = /http:\/\/v\.youku\.com\/v_show\/id_(\w+)\.html/
str = 'http://v.youku.com/v_show/id_XNTg3OTc3MzY4.html'
subst = '$1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result