using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"http://v\.youku\.com/v_show/id_(\w+)\.html";
string substitution = @"$1";
string input = @"http://v.youku.com/v_show/id_XNTg3OTc3MzY4.html";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}