import Foundation
let pattern = #"http://v\.youku\.com/v_show/id_(\w+)\.html"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"http://v.youku.com/v_show/id_XNTg3OTc3MzY4.html"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}