import re
regex = re.compile(r"http://v\.youku\.com/v_show/id_(\w+)\.html")
test_str = "http://v.youku.com/v_show/id_XNTg3OTc3MzY4.html"
subst = "$1"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)