// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"http://v\.youku\.com/v_show/id_(\w+)\.html").unwrap();
let string = "http://v.youku.com/v_show/id_XNTg3OTc3MzY4.html";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}