#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^([^=]+)=(\d+)\n(.*?)\1=\d+"
Local $sString = "test2=5" & @CRLF & _
"test=39&test2=4&test3=10"
Local $sSubst = "$3$1=$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)