use strict;
my $str = 'test2=5
test=39&test2=4&test3=10';
my $regex = qr/^([^=]+)=(\d+)\n(.*?)\1=\d+/p;
my $subst = '$3$1=$2';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";