re = /^([^=]+)=(\d+)\n(.*?)\1=\d+/
str = 'test2=5
test=39&test2=4&test3=10'
subst = '$3$1=$2'
result = str.sub(re, subst)
# Print the result of the substitution
puts result