import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^=]+)=(\\d+)\\n(.*?)\\1=\\d+";
final String string = "test2=5\n"
+ "test=39&test2=4&test3=10";
final String subst = "$3$1=$2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}