using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^=]+)=(\d+)\n(.*?)\1=\d+";
string substitution = @"$3$1=$2";
string input = @"test2=5
test=39&test2=4&test3=10";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}