import re
regex = re.compile(r"^([^=]+)=(\d+)\n(.*?)\1=\d+")
test_str = ("test2=5\n"
"test=39&test2=4&test3=10")
subst = "$3$1=$2"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)