import Foundation
let pattern = #"^([^=]+)=(\d+)\n(.*?)\1=\d+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
test2=5
test=39&test2=4&test3=10
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$3$1=$2"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}