# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?:[A-Z]\.)+[A-Z]?|[a-zA-Z']+)/$1\n/g;t' <<< "Consider this sentence: I studied at U.C.L.A in U.S.A.. One of my professors' kid was my best friend."