package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?:[A-Z]\.)+[A-Z]?|[a-zA-Z']+)`)
var str = `Consider this sentence: I studied at U.C.L.A in U.S.A.. One of my professors' kid was my best friend.`
var substitution = "$1\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}