using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:[A-Z]\.)+[A-Z]?|[a-zA-Z']+)";
string substitution = @"$1\n";
string input = @"Consider this sentence: I studied at U.C.L.A in U.S.A.. One of my professors' kid was my best friend.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}