// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((?:[A-Z]\.)+[A-Z]?|[a-zA-Z']+)").unwrap();
let string = "Consider this sentence: I studied at U.C.L.A in U.S.A.. One of my professors' kid was my best friend.";
let substitution = "$1\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}