re = /((?:[A-Z]\.)+[A-Z]?|[a-zA-Z']+)/
str = 'Consider this sentence: I studied at U.C.L.A in U.S.A.. One of my professors\' kid was my best friend.'
subst = '$1\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result