use strict;
my $str = 'Consider this sentence: I studied at U.C.L.A in U.S.A.. One of my professors\' kid was my best friend.';
my $regex = qr/((?:[A-Z]\.)+[A-Z]?|[a-zA-Z']+)/p;
my $subst = '$1\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";