$re = '/((?:[A-Z]\.)+[A-Z]?|[a-zA-Z\']+)/';
$str = 'Consider this sentence: I studied at U.C.L.A in U.S.A.. One of my professors\' kid was my best friend.';
$subst = "$1\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;